Official Error Reporting Topic

Report any errors from the L:AZ public files here
Post Reply
User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Official Error Reporting Topic

Post by Melchior Dahrk » Sat Aug 01, 2015 12:58 pm

Please use this topic to post all bugs and errors you may run into while using the alpha. Note the guidelines below:
  • When posting a report here please include your warnings.txt (in a spoiler code to save space), your mod list, and all other info you think may be relevant (location, object ID, etc).
  • Note that if you are reporting a floating object, you can upload a screenshot to your post, once I resolve it we can remove the file to save our host some space!
  • Remember: missing features are not bugs (e.g. missing dialogue, incomplete interiors, etc.). This mod is in ALPHA meaning that it is not feature complete. But things like floating objects, things which crash the game (cause CTDs or freezes), missing textures, missing meshes, etc. are all bugs.
Thank you for your help!

User avatar
berry
PT Modder
Posts: 670
Joined: Fri Jan 16, 2015 4:16 pm

Re: Official Error Reporting Topic

Post by berry » Sat Aug 01, 2015 2:28 pm

Hey, Melchior! First, let me congratulate you on this, it's a jaw-dropping work. I have never seen so swampy swamps in any PC game, and that temple district in Azura town... wow. I loved it.

I noticed some errors some weeks ago when I first played it, but I never could quite get to post about it, as I am rarely active on Bethesda's boards and Nexus. Well, anyway:
[hsimg=]http://i.imgur.com/zznVr7W.png[/hsimg]

This guy needs to have a Greeting value of 0, otherwise it may result in what's happening on a screen above.

[hsimg=]http://i.imgur.com/1Aim6VU.png[/hsimg]

[hsimg=]http://i.imgur.com/1yQeWrW.png[/hsimg]

[hsimg=]http://i.imgur.com/GSICPCy.png[/hsimg]

[hsimg=]http://i.imgur.com/i0FWLB2.png[/hsimg]

[hsimg=]http://i.imgur.com/kEcyt2x.png[/hsimg]

[hsimg=]http://i.imgur.com/1mNTyDu.png[/hsimg]

Also, that cute garden next to the mountain shrine to Boethia, with hedge Azura sculptures, was extremely laggy. I bet Azura models, being quite high poly, were to blame here? All of these errors were encountered in the first version you released, I haven't yet had enough time to check for updates.

Cheers :)

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Sat Aug 01, 2015 2:33 pm

Exactly the type of stuff I need. Thanks, berry! That gorge will be a beast to fix up, but I'll see what I can do!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Tue Aug 04, 2015 4:15 pm

Alright, all of the issues reported by berry are fixed for the next version aside from the Rose Atronach shadow. I've never worked with shadows before, so that might take a bit more work.

User avatar
Moritius
PT Modder
Posts: 216
Joined: Sat Aug 08, 2015 3:30 pm
Location: Poland

Re: Official Error Reporting Topic

Post by Moritius » Sun Aug 23, 2015 9:59 pm

Daedra Slayer's Guide (all volumes) have missing textures. I'm not sure, intettionally or not ;).
<ThomasRuz> A cleansing potion, with a nasty side-effect
<rotouns> Drain Spear 50 / 3600s
<ThomasRuz> We shall call it... the potion of impotency!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Mon Aug 24, 2015 1:22 am

Thanks, looks like I missed copying those over.

User avatar
Moritius
PT Modder
Posts: 216
Joined: Sat Aug 08, 2015 3:30 pm
Location: Poland

Re: Official Error Reporting Topic

Post by Moritius » Mon Aug 24, 2015 2:50 pm

Not a problem ;).

And, there's some alpha issues...
[hsimg=]http://i.imgur.com/30kYdne.jpg[/hsimg]
"az_light_v_brazier_necro"/"az_light_v_brazier_wall_necro"
<ThomasRuz> A cleansing potion, with a nasty side-effect
<rotouns> Drain Spear 50 / 3600s
<ThomasRuz> We shall call it... the potion of impotency!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Mon Aug 24, 2015 5:06 pm

Yeah I mentioned in the other thread that mesh had issues with alpha settings. It's definitely a WIP. Morrowind Doesn't like alpha on top of alpha very much...

User avatar
Moritius
PT Modder
Posts: 216
Joined: Sat Aug 08, 2015 3:30 pm
Location: Poland

Re: Official Error Reporting Topic

Post by Moritius » Mon Aug 24, 2015 6:54 pm

Yeah, I know, Morrowind and Oblivion (if I recall correctly) doesn't like multiply alpha layers. But, I didn't saw your mentions so I reported it anyway ;).
<ThomasRuz> A cleansing potion, with a nasty side-effect
<rotouns> Drain Spear 50 / 3600s
<ThomasRuz> We shall call it... the potion of impotency!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Mon Aug 24, 2015 6:55 pm

Hopefully I can tweak it so that it works this way. I like the look of the flame in the crystal. Sometimes the z buffer property works and sometimes changing the alpha settings works. We'll see.

User avatar
Moritius
PT Modder
Posts: 216
Joined: Sat Aug 08, 2015 3:30 pm
Location: Poland

Re: Official Error Reporting Topic

Post by Moritius » Tue Aug 25, 2015 1:44 pm

I wanted to watch assets and found something:
"az_in_dae_dj_01" has gap in it http://i.imgur.com/MVLvsHY.png
"az_flora_fire_grass" - I dunno what it behavior in game, but in CS shows me something strange http://i.imgur.com/ry2YItM.png
<ThomasRuz> A cleansing potion, with a nasty side-effect
<rotouns> Drain Spear 50 / 3600s
<ThomasRuz> We shall call it... the potion of impotency!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Tue Aug 25, 2015 3:10 pm

Thanks for the dj report. I'll take a look at that mesh.

Something strange is going on with the fire grass. When I was running my tests initially it was fine, abot found something similar to what you're showing but when I looked at it, I could not recreate the issue. So I'll take another peek... I'm curious if it looks that way in game for you. I think I have a cell named "Infernace, [insert clever name here]" where the fire grass is used. You could check it out there.

User avatar
Moritius
PT Modder
Posts: 216
Joined: Sat Aug 08, 2015 3:30 pm
Location: Poland

Re: Official Error Reporting Topic

Post by Moritius » Wed Aug 26, 2015 12:47 am

In game it looks alike. I checked mesh - there's filepath "textures\az\firegrass_emissive.tga". In "az" folder are two files - "firegrass_emissive.tga" and "firegrass_emissive.dds". I checked them and neither .tga nor .dds have alpha channels with transparency on black parts.
<ThomasRuz> A cleansing potion, with a nasty side-effect
<rotouns> Drain Spear 50 / 3600s
<ThomasRuz> We shall call it... the potion of impotency!

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Wed Aug 26, 2015 3:02 am

Alright, fixed for the next update. The diffuse texture was missing. Thanks, Moritius!

User avatar
Lord Berandas
PT Modder
Posts: 127
Joined: Sat Jan 03, 2015 6:57 pm
Location: Prague, Czech Republic
Contact:

Re: Official Error Reporting Topic

Post by Lord Berandas » Sun Mar 13, 2016 10:20 pm

Hey! I did a quick walkthrough and find some issues, here they are:

az_door_cavern_blocked Scabrous Residuum, Tarshon (50,-24) 410741 -196222 396 "gap above door"
az_door_cavern_blocked Scabrous Residuum, Tarshon (49,-24) 409077 -195900 396 "here as well"
az_cont_corpse_hanging Scabrous Residuum, Tarshon (50,-24) 415095 -196575 1264 "is this rotated properly?"
az_dae_sigil_golem "his right hand mesh is not connected to the rest of his body properly"
az_siika_elvenship_01_furl "missing or inverted faces of the mesh in the front part"
az_water_waterfall_OM Azurian Isles, Isles of Dusk (55,-17) 453729 -134022 2393 "can be seen from the other side of the tower"
az_rock_UW_sach_chasm2 Azurian Isles Region (56,-15) 462202 -118086 -1864 "there is a weirdly oriented grass piece by this rock"
az_ex_v_block20 Azura, Poor Town (58,-23) 482400 -185055 1185 "there are two grass pieces growing from the bricks here"

Also your mod is incompatible with this ship replacer:
http://www.nexusmods.com/morrowind/mods/44001" onclick="window.open(this.href);return false;
Especially in that village composed of ship parts.

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Tue Apr 26, 2016 12:26 am

Lord Berandas wrote:Hey! I did a quick walkthrough and find some issues, here they are:

Also your mod is incompatible with this ship replacer:
http://www.nexusmods.com/morrowind/mods/44001" onclick="window.open(this.href);return false;
Especially in that village composed of ship parts.
Crap, I have been meaning to check back on this forum. And I see I missed this. So here we go:

az_door_cavern_blocked Scabrous Residuum, Tarshon (50,-24) 410741 -196222 396 "gap above door" --> fixed
az_door_cavern_blocked Scabrous Residuum, Tarshon (49,-24) 409077 -195900 396 "here as well" --> fixed
az_cont_corpse_hanging Scabrous Residuum, Tarshon (50,-24) 415095 -196575 1264 "is this rotated properly?" --> lol wtf. fixed.
az_dae_sigil_golem "his right hand mesh is not connected to the rest of his body properly" --> I tweaked it
az_siika_elvenship_01_furl "missing or inverted faces of the mesh in the front part" --> do you have a picture? I'm not seeing issues on the mesh
az_water_waterfall_OM Azurian Isles, Isles of Dusk (55,-17) 453729 -134022 2393 "can be seen from the other side of the tower" --> fixed
az_rock_UW_sach_chasm2 Azurian Isles Region (56,-15) 462202 -118086 -1864 "there is a weirdly oriented grass piece by this rock" --> fixed... I think
az_ex_v_block20 Azura, Poor Town (58,-23) 482400 -185055 1185 "there are two grass pieces growing from the bricks here" --> fixed... I think

Hmm... good point about Crab's mod. I'll have to think about how I want to address that.

User avatar
Lord Berandas
PT Modder
Posts: 127
Joined: Sat Jan 03, 2015 6:57 pm
Location: Prague, Czech Republic
Contact:

Re: Official Error Reporting Topic

Post by Lord Berandas » Tue Apr 26, 2016 4:28 pm

Here is the screenshot.

Image

Also the incompatibility with that mesh replacer isn't a big problem I think, it causes way too many errors with any other content, so I don't use it anyway. (It has the meshes very well done though.)

User avatar
Melchior Dahrk
Forumite
Posts: 164
Joined: Mon Jan 12, 2015 12:58 am

Re: Official Error Reporting Topic

Post by Melchior Dahrk » Wed Apr 27, 2016 12:39 am

Oh, that issue. Thanks, Berandas. Yes, that one has been fixed for the next version; along with some other cleanup on the model.

For now, I'll probably just note it as a kjnown incompatibility, so thank you for the heads up.

Post Reply

Return to “L:AZ Playtesting & Error Reporting”

Who is online

Users browsing this forum: No registered users and 1 guest